Errors JavaScript

How to fix “Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3” error

This javascript error shows up when you have bootstrap version 3.3 or lower on your website. The bootstrap javascript file needs an older version of jQuery, which is lower than version 3. To fix it, you simply have to install the latest bootstrap 3 javascript file, which is version 3.4.1. You can download bootstrap version


How to fix $.browser undefined error in WordPress

$.browser function has been deprecated from the latest jQuery version. It had the flags $.browser.webkit, $.browser.safari, $.browser.opera, $.browser.msie and $.browser.mozilla to detect respective browsers in previous versions. But now, if your site has code with these flags and your theme has the latest version of jQuery, then it will throw an error message sayings “undefined”.